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Introduction to Pentaho Report Designer

Pentaho Report Designer is a sophisticated report creation tool that you can use standalone, or as part of the
larger Pentaho Business Analytics distribution. It enables professionals to create highly detailed reports based
on adequately prepared data from virtually any data source. The purpose of this document is to provide

instructions for creating a simple Report Designer report.

This section contains walk-throughs for creating content in Report Designer. You must have Pentaho's sample
database installed and available in order to follow the tutorials. Sample data is installed by default with Report
Designer, though you or your system administrator may have removed it prior to production deployment. If it's
been removed, you can simply reinstall Report Designer to get it back.
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Create a Report with Report Designer

Follow the instructions below to begin creating your report:

1.

Start the Report Designer. Go to Start > Programs > Pentaho Enterprise Edition > Design Tools >
Report Designer. The Report Designer home page appears.

Click New Report in the Welcome dialog box. The design workspace appears.

Note: If you'd like to change the size of the layout bands to give yourself more area to work in without
changing the dimensions of the published report, you can click and drag the percentage number in the
upper left corner of the workspace. By default it says 100%, but if you click and drag it diagonally
toward the upper left or lower right corners, the view will zoom in or out. If you want to reset the view
to 100%, double-click the upper left corner where the percentage shows.

In the right pane, click the Data tab.
For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click the

yellow database icon to display the JDBC dialog box. The JDBC Data Source dialog box appears.

Under Connections, select SampleData (Memory).
Next to Available Queries click

o
(Add). Query 1 appears under Available Queries. Notice that the edit icon
&

is enabled.

~ JDBC Data Source
Connections: . & 63 me’ (#] ]
|sampleData (Hypersonic) |Query 1
SampleData [Local)

SampleData (MySQL)

7. Click
&
(Edit). The SQL Query Designer window opens. The SQL Query Designer provides you with a graphical
environment that allows you to work with the data even if you don't understand SQL, the standard
programming language for retrieving content from databases.

8. Double-click ORDERFACT so that the table appears in the workspace as shown in the image above.

9. Inthe SQL Query Designer workspace, right-click "ORDERFACT" and choose deselect all.
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[¥] STATUS

[l COMMENTS

[¥] CUSTOMERNUMBER
[¥] TIME_ID

[¥] GTR_ID

[ MONTH_ID

[¥] YEAR_ID

10. Now, select the following fields in the ORDERFACT table: ORDERNUMBER, QUANTITYORDERED,
PRICEEACH, and ORDERDATE.

[¥] ORDERMUMBER -
[[1PRODUCTCODE
[¥] QUANTITYORD

] PRICEEACH
n ﬂRﬂERLNENUM%
[ TOTALPRICE

¥] ORDERDATE }
[ REQGUIREDDATE

[_] SHIPPEDDATE
[]sTATUS

11. Double-click PRODUCTS so that the table appears in the workspace. Notice that there is a line that joins
the ORDERFACT and PRODUCTS tables together.

12. Deselect all PRODUCTS table fields, except for PRODUCTNAME and PRODUCTLINE.

[*] ORDERNUMBER -

[]PRODUCTCODE PRODUCTNAME

v QUANTITYORDERED [w] PRODUCTLINE

[¥] PRICEEACH ] FRODUCTSCALE
[ ORDERLUINENUMBER, ] PRODUCTVENDOR
[ TOTALPRICE ] PRODUCTDESCRIPTION
[¥] ORDERDATE ] QUANTITYINSTOCK
] REQUIREDDATE [] BUYPRICE

[ sHIPPEDDATE | C]mssp

[L]STATUS

[ COMMENTS

[ CUSTOMERNUMBER

[C] TIME _IDy

LJaTmR_ID

Ll MOoNTH_ID

PREARD P et -

13. For the purpose of this exercise, click the Syntax tab in the lower left portion of the SQL Query Designer
workspace to display a simple SQL statement associated with the tables. Notice that PRODUCTCODE is
the common field between the ORDERFACT and PRODUCTS tables.
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SELECT
"ORDEREACT™ . "ORDERNIMEER",
“ORDEREACT ™. “QUANTITYORDERED™,
"CRDERFACT" . "FRICEEACH",
"ORDERFACT™ . "CROERDATE™,
“PRODUCTS" . ~PRODUCTHAME=,
“FRODUCTS" . FRODOCTLINE®

FROM

"PRODOCTS" IHHER JOIN "CRDERFACT™ ON "FRODDCIS”."PRODDCTCODE" = "ORDERFACT™."PRODDCTCODE"

14. Click OK in the syntax window to return to the JDBC Data Source dialog box. Notice that the SQL
statement appears on the right under Query.

15. Inthe JDBC Data Source dialog box, click OK to return to the Design page. Notice that the fields
associated with your tables are listed under Query 1. You are now ready to start designing your report.

%
0 f 3
¥ D) Data Sets

v = JUBL Samplelata (Hypersonic)

7 [ auery 1 4
[ ORDERNUMBER: {Integer) fﬂj
| QUANTITYORDERED (Integer) ™,
[¥ PRICEEACH (BigDecimal) 3
|| ORDERDATE (Timestamp)
¥ PRODUCTNAME (Siring) b
[ PRODUCTLIME (String)

ORDERNUMBER: (;:column::0) j
QUANTITYORDERED (-column:
PRICEEACH (-columin:2) }
_ | DRDERDATE ( column=3)

| 1 PRODUCTMNAME (-:column::4) 3

i || PRODUCTLINE (column-5)
MWM

+ Design Your Report

+ Refine Your Report

+ Add a Chart to Your Report

+ Add Parameters to Your Report
* Publish Your Report
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Design Your Report

This exercise walks you through the process of designing the look-and-feel of your report.

1. Under the View item in the Report Designer menu bar, click Element Alignment Hints and Snap to
Elements to enable them. These options help you to align the elements of your report.

2. Inthe Design page, under Query 1, click and drag the ORDERNUMBER field into the Details band.
Make sure that the top line of the field name and the top line of the Details band match up.

3. Place the ORDERDATE, PRODUCTNAME, QUANTITYORDERED, and PRICEEACH fields into the Details
Band. Take care not to overlap the fields or your report will not display correctly.

4. Use the resizing handles to make the PRODUCTNAMIE field larger and the QUANTITYORDERED field
smaller as shown in the example below:

ORDERMNUMBER ORDERDATE E QLUAN . PRICEEACH
. @

- w

= Fesizing Handle

Loy

5. You have created your first report. Click

=]

(Preview) to examine your report. Click

&
(Edit) to return to the workspace view.
Tip: You can also click

@l
(Preview) on the left side of your workspace or select it from the View menu option to preview a report.
Click

rd

(Edit) to return to the workspace view.
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10,107
10121
10,134
10,145
10,159
10,168
10,180
10,188
10,201
10,11
10,223
10,237
10,251
10,23
10,275
10,785
10,249
10,309
10,318
10,329
10,3401
10,354
10,381
10,375
10,338
10,349
10,403
1007
10,103

Feb 24, 2003
May 7, 2003
Jul i, 2003
Aug 25, 2003
Qct 10, 2003
Oct 28, 2003
Mow 11, 2003
New 18, 2003
Dac 1, 2003
Jan 15, 2004
Fab 20, 2004
Apr S, 2004
May 18, 2004
Jun 28, 2004
Jul 23, 2004
Aug 27, 2004
Sap 30, 2004
Oct 15, 2004
Mow 2, 2004
Miow 15, 2004
Mow 24, 2004
Dec 4, 2004
Dac 17, 2004
Fab 3, 2005
Mar 3, 2005
Apri, 2005
Apr &, 2005
May 13, 2005
Jan 9, 2003

1969 Harley Davidson LItimate Cho .

14969 Harley Davidson Utimate Cho

1964 Harley Davidson Ultimate Cho ..
1969 Harley Davidson Limate Cho
1969 Harley Davidson URimate Cho ..

1969 Harley Davidson Uimate Cho

1968 Harley Davidson Ultimate Cho .. 2
1969 Harley Davidson URimate Cho
1969 Harley Davidson LURimate Cho .

1969 Harley Davidson Uimate Cho

1468 Harley Davidson Ultimata Cho ..
1969 Harley Davidson URimate Cho
19649 Harley Davidson Uimate Cho .

1969 Harley Davidson Utimate Cho

1964 Harley Davidson Ultimate Cho ..
1969 Harley Davidson URimate Cho
1969 Harley Davidson URimate Cho .

1969 Harley Davidson Utimate Cho

1968 Harley Davidson Ultimata Cho ..
1969 Harley Davidson URimate Cho .
1969 Harley Davidson LUimate Cho .

14969 Harley Davidson Utimate Cho

1969 Harley Davidson Ulimate Cho .
1869 Harley Davidson LIRimata Cha
1969 Harley Davidson LRimate Cho ..

1969 Harley Davidson Utimate Chio

1964 Harley Davidson Ultimate Cho ..
1969 Harley Davidson Uimate Cho

1952 Alpine Ranaui 1300

E-Bi

857
B1.35
a4 74
BN
100
46 65
BE 13
100
98.57
100
100
100

¢

4

*

¢

wu ?
j

BE.13
7255
kTR
76,35
100
100
mu

'INJ 'a;&\‘?« ﬂﬂiﬂ :*s- n:n b

But, wait... There's a problem. Without headers, report users will have a hard time understanding its

content. You must continue refining your report, see refining your report.
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Add a Chart to Your Report

So far you've seen a small subset of features associated with Report Designer. In this exercise, you will add a

chart to your report.

1. Click File > Open and find the report you just saved. Click OK.
2. Inthe palette, click and drag a

(@]
Chart into the Report Footer band.

3. Use the resizing handles to center and stretch the chart. You can also adjust the width of the band.

Bar Chart

Double-click the sample chart.

5. The type of chart most appropriate for your report is a pie chart. In the top portion of the Edit Chart
dialog box, select the pie chart icon.
Note: Notice that the pie chart properties that define its look-and-feel are listed in the left pane of the
Edit Chart dialog box. Properties associated with the data in the chart are listed in the right pane.

Go to the Title properties; net to the chart-title property, type Product Pie Chart.

Under Common, click the down arrow next to value-column click the ellipsis [...] to open the Edit Array
dialog box.

The value-column specifies the actual values (measures) you want to chart. In this instance, you want to

chart the quantity ordered.
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12.

13.
14.
15.
16.

17.

Primary DataSource | Sccondany DalaSowce

| = ” 4 ” i | Click here
Pie Data Set Callector

B Coaniman

] QUANTITYORDERED (java.lang.intager)
D) PRICEEACH (avamath.BigDecimal) -
) ORDERDATE {java.sgl. Timestampy
D PRODUCTHAME (java.kang. String)
£ PRODUCTLINE (javalang String) -

[ox ][ conos

Click in the blank field to expose the drop-down arrow.
Select QUANTITYORDERED from the list and click OK.
Click OK to exit the Edit Chart dialog box.

Under Series click the ellipsis [...] next to series-by-field to open the Edit Array dialog box.

The series-by-field specifies the field you are charting. In this instance you are charting by product line.

Series are usually placed in the chart legend.

Click

o

(Add).

Click in the blank field to expose the drop-down arrow.

Select PRODUCTLINE from the list and click OK.

Click OK to exit the Edit Chart dialog box.

Click

=]

(Preview) to display your report.

When the report displays, click the double arrows to go to the last page.

Product Bar Chart

B Motorcycies @ Clessic Cars () Trucks and Busas () Vinlage Cars ) Planes () Ships () Trains
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The chart you created appears on the last page of the report. If you want to display a bar or line chart
instead, use the chart settings below. You have to add the series-by-value setting manually in the Edit

Array dialog box. Click

¥
(Add) and type SALES; click

o
(Add) and type COST. Run the report to display the bar chart.

categony-column PRODUCTLINE
[QUANTITYORDERED, PRICEEACH]

sernies-by-valug [SALES, COST]
sernies-by-field ]
auic-generate-cenes

Product Bar Chart

THOO0 1

0000 1

Vales

Trucks &...

Sares
Mooy, .. [e=" Winrla., Plarms

Series Categories

18. Save your report. You are now ready to add a parameter to your report.
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Add Parameters to Your Report

When you set parameters, users are prompted for a value or values when they run the report. The ability to

provide parameters is an important part of creating a report.

1.
2.

AN A S

In the Report Designer, click File > Open to select the report you created.
In the menubar go to Data > Add Parameter. Alternatively, you can click

(=]

(Master Report Parameter) under the Data Tab in the Report Designer workspace. The Add Parameter
dialog box appears.

In the Add Parameter dialog box, type enter_prodline in the Name text field.
Type Select Line in the Label text field.

Next to Display Type, select Drop Down so users can select a product line.
Click

rd

(Edit) to add a query that supplies the values, (motorcycles, cars, ships, and so on), from which users of
the report must choose.

Note: Click on JDBC (SampleData - Memory) under Data Sources if the Edit icon is disabled.

The JDBC Data Sources dialog box appears.

Under Connections, select SampleData (Memory).
Next to Available Queries click

L]
(Add). A new query placeholder is added to the list (Query 2).

In the Query Name text field, type prodlineList.

Enter your SQL query in the Query box. You can copy and paste the required lines, (shown below)
directly into the SQL statement or you can use the alternate steps in the table below.

Important: Make sure to use curly brackets, (not parentheses), before and after {enter_prodline} or the
report will not display correctly.

SELECT DISTINCT "PRODUCTS"."PRODUCTLINE"

FROM "PRODUCTS"

Query Hame
prodiinelist

Query
| SELECT DISTINCT
z "PRODUCTS" . "PRODUCTLINE"
7 FROM
4 " PRODUCTS"

https://help.pentaho.com/Documentation/5.2/0J0/0E0/010/010 13/27
Updated: Tue, 30 Sep 2014 01:18:46 GMT



By entering these lines, report users see a prompt when they open the report in the Pentaho User
Console that allows them to enter a product line. That way, they can examine orders by product line. If

you do not add the lines, the report displays orders for all product lines.
Alternatively, you can use the SQL Query Designer to build your query:

Step Description

1 In the JDBC Data Source dialog box, click
&
(the Edit icon on the right).

2 In the SQL Query Designer, select the PRODUCTS
table on the left.

3 On the right, click PRODUCTS and choose Deselect
All.

4 Right-click SELECT on the left and choose Distinct.

5 On the right, select PRODUCTLINE and click Preview.
The product line list appears. Click Close.

6 Click OK to exit the SQL Query Designer and go to
Step 11.

11. Click OK to exit Data Source dialog box.

12. In the Add Parameter dialog box, under Data Sources, double-click JDBC SampleData (Memory) and
select prodlineList.

13. Next to Value Type, select String.
14. Type a default value, for example, "Motorcycles," in the Default Value text box. (Optional)

<
DataSources @ s 8
7 JDBC (SampleData (Memary))|  Name enter_prodiing
[ prodimeList Label Saled Line
[ cuery 1 Vialue Type r :
Data Format |
Default Value Matorcycles
Dietault Value Formula .
Post-Processang Formula |
"] Mandatory
[] Hidden
Dispiay Type Drop Down 2
Query FH‘DI:Inel.mt (
Value |PHDDL[TIJPE
Display Hame |PHDDLN:TIJIE
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15. Click OK to exit the Add Parameter dialog box.

16. Now that you've created a product line parameter, you must map it back to your query (Query 1).
Under Data, double-click Query 1.

D i

1D Data Sets
# =] JOBC (SampleDuats (Hyprs ol
[ wodnetiss
7 2 ey
D) CROEFRNUMBER (OROERMUMSEER, I

D) QUANTITYORDERED (OUWHTITYORDY
[} PRICEEACH (FRICEEACH, BigDecimy
[} GROEFDATE ([OROERDATE, Timests
[} PROCUCTRAME (PROCUCTHASE, 53

17. Right-click PRODUCTLINE and select add where condition. The condition.edit dialog box appears.
18. Type S {enter prodline} inthe editareaand click OK.

= condition.edit

]

MPRODUCTS™ PRODUCTLUIMNE

= v |[[] SUBQUERY
B{enter_prodiine} ﬁ Use {curly brackets} not
{parentheses) around your

text!
| ok || close
_

19. Click OK to exit the /SQL Query Designer.
20. Click OK to exit the Data Source dialog box.
21. Click

=

(Preview).
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Orders

ke Dan ot S
el AT Al Ramalt |

Lt Y Al Ramanslt |

el Y A el |

L] A S Wamal |

You should see your product line drop-down list.
22. You are now ready to publish your report.
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Publish Your Report

You have created and formatted a simple report, added a chart, and now you are ready to share the report

with your users.

1. In the Report Designer, click File > Open to open the report you just created.
2. Click File > Publish. Alternatively, click

]

. If you have not saved the report, a warning message reminds you to save it. The Login dialog box
appears, pre-populated with credentials valid for the evaluation. Make sure that the Server URL is set to
http://localhost:8080/pentaho/.

ntip:ifocainost:1 8080ipentanol | ?
Pentaho Credentials f
User: .
joe ,
= 3

Click OK. The Publish to Server dialog box appears.
In the Publish to Server dialog box, type in a report name and description into the appropriate fields.
Under Location, save the reportinthe .../steel-wheels/reports folder.

Select html as the Output Type and click OK. A success message appears.

N o vk~ W

Click Yes to go directly to the User Console to view the report you just published. If you want to access
the report later, log into the BA Server by going to http:// localhost:8080 in your Web browser, then
navigate to the Reporting Examples directory in the Solution Browser. You should see your published
report in the list. If not, click Tools > Refresh Repository.

Log in as Admin. The default admin password is password.
9. Your report displays in the User Console. You now have a report that users can view at any time.
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http://localhost

[W14] Page [ of 31 [»]#]

Order Report
Order Mo, Order Date Product Name Quan. Price Each
10,233 Jon-01-2004 1570 Phvmouth Hemi Cuda 23 90.17
10,266 Jal-06- 2004 1970 Plvesouth Hemi Cuda 35 T6.61
10,276 Aug-02-2004 1970 Plymouth Hemi Cuda is 53789
10,287 Aug-30-2004 1970 Plymouth Hemi Cuda 41 69.43
10,300 Oct-04- 2003 1970 Plymsouth Hemi Cuda 2 T6.61
10,310 Oct-16-2004 1970 Plvmsouth Hemi Cuda 49 Bl4
10,320 Wow-03-2004 1970 Plymouth Hemi Cuda £ 7342

10,329 Nov-15-2004 1970 Plymouth Hemi Cuda 33 100 -
. G- 24.2 ;
"}Ef' - : ~J?W ashpamnamt i, i 'N

10. Inthe User Console select your product line parameter from the drop-down list. Accept the default
under Output Type.
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Refine Your Report

You have created a report in the previous exercise but now you need to make the report more descriptive so
that users can understand the content in the report. Follow these instructions to refine your report.

1. Click

V4

(Edit) to return to the Design page.
2. Clickand drag a

Ab
(Label) from the tools palette into the middle of the Page Header band. Notice how Report Designer
keeps track of the report structure (shown below).

3 Group Header
o [ = Details Body
= Group Footer
& el Report Footer
& ol Page Footer
| Watermark

3. Click inside the Label item and type Order Report

4. Double-click inside the Order Report label to select the text, then in the toolbar, select a larger font size
(18 point) and apply boldface.
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10.

11.

12.

13.

14.

Rl PIEEIE
+18-20:22 24 - 26-28-30:3.2 34 -36-38 40 .42 -4
Q
[= ]

Order Reportz

...................... . P~ SRR

The changes are applied to the text; however, now that the text is bigger you may not see all of it, so
use your resizing handles and enlarge the label until you can see all of the text. Alternatively, you can
stretch the resizing handles all the way to each edge of the workspace and click the align center icon in
the toolbar so that the text is automatically placed in the center of the report page.

With the Order Report label still selected, click down arrow of the font color icon in the toolbar. Select a
color for your label. The font color changes. This page header will appear on every page of your report.

Now, you must create column headers. On the right side of your workspace, click Structure -> Details
Header.

In the lower right section of your workspace, click Attributes.

Under common, change the Value of the hide-on-canvas option to False. Notice that the Details
Header pane appears in your workspace.

In the toolbar, click
]
(Select Objects). Notice that the icon changes to a cross hair as you move into the workspace.

Move your mouse to the far right of the Details pane. Now, drag your mouse to the far left over all your
column objects to select them. You may have to move the mouse under the headings to make them
easier to select.

b

d a - T .. T . P . T TT——r . p— I - Yy - ' Ty o

Delails

Click <CTRL+C> to copy your objects and <CTRL+V> to paste them into the Details Header pane.
Note: Alternatively, you can choose Copy from the right-click menu.

Under Format in the Report Designer menubar, select Morph. The column objects are changed to
labels.

Type the correct heading names for each of your columns: Order No., Order Date, Product Name,
Quan., and Price Each. Your headers will align correctly over your columns.

Click

&
(Preview) to display your report.
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Order Report

ﬂﬂ E! Drec II Wﬁ Harley Davidson Ulu?ampper ’

Order No. Order Dale  Produc Hame Quan. Price Each
10,107 Feb 24, 2003 1568 Harley Davidson Ultimate Chopper 30 a5y

1011 May 7,2003 1569 Harley Davidson Ultimate Chopper 34 B1.35 g
10,134 Jul 1, 2003 1969 Harley Davidson Uitirmate Choppar 41 8474

10,145 Aug 25, 2003 1969 Harley Davidson Uttimate Chopper 45 B1X

10,153 Cct 10, 2003 1965 Harley Davidson Ultimate Chopper 49 100

10,168 Oct 28, 2003 1960 Harley Davidson Ultimate Chopper 38 Q665

10,180 Mow 11, 2003 1969 Haley Dawidson Ultimate Chopper 29 BE13

10,188 Mow 18, 2002 1969 Harley Davidson Ultimate Chopper 48 100 é
10,201 Dt 1, 2003 1968 Harley Davidson Ultimate Chopper 22 Q8. 57 m
10,211 Jan 15, 2004 1965 Harley Dawidson Ultirmate Choppar 41 100

10,223 Feb 20, 2004 15% Harley Davidson Ultimate Chopper 37 100

10,237 AprS, 2004 196% Harley Davidson Ultimate Chopper 23 100

10,251 May 18, 2004 1955 Harley Davidson Ultimate Chopper 28 100

10,263 Jun 28, 2004 1969 Harley Davidson Ultimate Choppar 34 100

10,275 Jul 23, 2004 1969 Harley Davidson Ultimate Chopper 45 9283
10,285 Aug IT, 2004 1980 Harley Davidson Ultimate Chopper 38 100

10,299 Sep 30, 2004 1955 Harley Davidson Ultimate Chopper 23 100

10, 304 Qet 15, 2004 1960 Haley Davidson Ultimate Choppar 41 .
10,18 Mov 2 2004 1960 Harley Davidson Ultimate Chopper 46

10,3259 Mow 15, 2004 1955 Harley Davidson Ultimate Chopper 42

10,34 Mo 24, 2004 1955 Harlay Davidson Ultirmate Choppar 41

10,354 Dec 4, 2004 1969 Harley Davidson Ultimate Chopper

The report looks good but you may want to make it even easier to read by applying some banding.

15. In the toolbar, go to Format -> Row Banding.

16. Inthe Row Banding dialog box, choose Yellow from the drop-down list next to Visible Color and click
OK.

17. Click

|

(Preview) to display your report.

Order Report \
irder No. Ahpder Diwie Product Same uan Price Each
o, 10T Mo Pt 24 1965 Hakey Davideon Ulsinwie Chopper 30 @87
OO0 EST
b 120 Wed May 07 1963 Harkey Davideos Ultimete Chopper M 8,38
Lo, 134 T Jul 0l 1965 Harley Davidsos Lleimue Chopped 41 4. '
0000 EDT .
L, 1 4% [T Y F.%'I' 1965 Moy Davideon Ulimoe Choppes 45 Ll ] - -,
o, | 4% Fri Qi 10 1% Tlabey Davidsos Ulsinwie Chopper 49 [T01]
0 00 EDT
I, |68 Thee Ot 28 1968 Harkey Davideos Ultimete Chopper 36 L
00D EST ..
L, |80 Tt Masww 1] 1965 Harley Davideos Lleimeie Chopped o LT E]
. OO0 EST
o, 1L T Naww 18 |t Dy s Ll lnime 48 [T0Y] 3
L, 000 00 S o
Vo, e e g e
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18. Inthe menubar, go to File -> Save to save your report in the ...\report-designer\samples folder. Type
Orders in the File Name text box.

Note: See More about Row Banding, Data Formatting, and Alignment for additional information about
refining your report.

* More about Row Banding, Data Formatting, and Alignment
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More about Row Banding, Data Formatting, and
Alignment

Row Banding

By creating a row band element, you can select the specific fields in your report that will display a row band. For
example, you may want to emphasize specific fields and not others on a line. You can give your row band

element any name you choose. In the example below, the row band element is called row-band-element.

(¥} Row Banding ..

Visicle Color  Jight_gray

Invisble Color  JAutomatic

Element row-nand-element
State on new Group| Invishle
State on new Fage | Same as initial stats

[ ok | Cancel
| oll|

After you create your element, go back to the report and select the columns (fields) whose data will always be
displayed with a row band. You must also type row-band-element in the name field under Attributes. is In the
example below, the data associated with each of the columns in the report will display a row band. Notice the
banding in the report preview.
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File Edit View Insert Format Data Extras Wimdow Help
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Data Formatting

Report Designer uses default formats for dates and numbers. You can change how dates and numbers display
by selecting the object (field) and selecting the appropriate value for the format from the drop-down list next
to format (under Attributes). In the example below, the dates associated with the Order Date field will display
as MM-dd-yy.
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File Edit View Insent Format Data Extras Window Help
Dsd@ 8|r k|loc| X%l X|&

wloel| B I U |uemote)| (B (3 [T [@ | ==
LS 2D 25 R0 - RS 40 - 45 - 50 . 55 . &b

Fape Header |10 Order Report

OREEENUMBER ap T QUAR PRICEEACH

Repaort Foobar

Page Fooler

DRI EBLBI0OCRPR|sBsEEERE

When you preview the report, notice that it displays in a cleaner format:

File Edit View Ingert Fesrnat Data Extrax Window Help
DESE® 0| k|wo| G0 x|
« | & oreenf3d |

s|ea|aera e,

Order Report

el [Dhstet Prihen Naier
02:28:01 1 By Darvideon

\:I‘J:II a1
I
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Note: You can type a value for your own format if you know the correct JavaScript string nomenclature.
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Alignment

To align multiple objects press <SHIFT+ CLICK> to select each object. Then, choose an alignment option from
the Format menu. Alternatively, you can click

(Select Objects) and drag your mouse over the objects you want to select and then choose an alignment
option.

In the example below, the selected objects will be aligned in the middle of the band.

ile Edit View ]nrsertIFun'nat Data Extras Window Help
D & E 9 | B | Font... Ctrl+1
*| |5 orders[X] Paragraph...

-:l:-|: Size and Borders... - | BIU || El E E' E
10096

Color and Background... C .30 .35 .40 .45 .50 .55 . &0 .

Conditional Hide...

Page Head Row-Banding.. rder Report

Edit Style Definition ...

Hyperlink...

Arrange

Report Hea Alignment
Distribute

Marph

ME O DUAN JRICEEACH
o

Chart ..

Edit Table-of-Contents ..
Edit Index ..
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Further Reading

This document was designed to quickly demonstrate basic Pentaho Report Designer features. See the Design
Print-Quality Reports section of Build Full-Featured Solutions on the Pentaho Infocenter for more about Report

Designer features and functions, from adding a data source to working with conditional formatting and
formulas.
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